码上敲享录 > maven开发经验分享 > maven的依赖包都存在了为什么还是Cannot resolve org.codehaus.groovy:groovy-all:2.5.8

maven的依赖包都存在了为什么还是Cannot resolve org.codehaus.groovy:groovy-all:2.5.8

上一章章节目录下一章 2020-01-04已有3835人阅读 评论(0)

maven的依赖包都存在了为什么还是Cannot resolve org.codehaus.groovy:groovy-all:2.5.8


解决方法:

例如下面的groovy-all已经下载下来了,鼠标可以点击进了

<dependency>

           <groupId>org.codehaus.groovy</groupId>

           <artifactId>groovy-all</artifactId>

           <version>2.5.8</version>

       </dependency>


原因是父的pom文件打包类型<packaging>pom</packaging>,所以要加<type>pom</type>

<dependency>

           <groupId>org.codehaus.groovy</groupId>

           <artifactId>groovy-all</artifactId>

           <version>2.5.8</version>

           <type>pom</type>

       </dependency>


向大家推荐《Activiti工作流实战教程》:https://xiaozhuanlan.com/activiti
向大家推荐《ireport实战教程》:https://xiaozhuanlan.com/ireport?rel=6923152725
1

有建议,请留言!

  • *您的姓名:

  • *所在城市:

  • *您的联系电话:

    *您的QQ:

  • 咨询问题:

  • 提 交