码上敲享录 > AngularJS详解 > ERROR in Error:Metadata version mismatch for module,found version 4, expected 3

ERROR in Error:Metadata version mismatch for module,found version 4, expected 3

上一章章节目录下一章 2017-12-01已有3761人阅读 评论(0)

问题描述:

昨天执行npm start 启动angular2项目还好好的,今天启动就报版本不匹配的错误,试过npm clean清除缓存,甚至还重新安装nodejs也不济于事

ERROR in Error: Metadata version mismatch for module E:/Demo/crud/
node_modules/@angular/material/card/typings/index.d.ts, found version 4, expected 3, resolving symbol AppModule in E:/Demo/crud/client/app/a pp.module.ts, resolving symbol AppModule in E:/Demo/crud/client/app/ap p.module.ts [1] at Error (native) [1] at syntaxError

解决方法:

在angular2项目中随便修改一下\src\app\pages\pages.routing.ts文件或者\src\app\app.routing.ts文件,可以打几个空格,然后保存,前端代码自动编译,就可以成功了,真的是简单了。

本文地址:http://www.yayihouse.com/yayishuwu/chapter/1049



Activiti工作流实战教程:https://xiaozhuanlan.com/activiti
10

有建议,请留言!

  • *您的姓名:

  • *所在城市:

  • *您的联系电话:

    *您的QQ:

  • 咨询问题:

  • 提 交